Host process for Function Discovery providers.
This service also exists in Windows 10, 11, 7 and 8.
| Windows Vista edition | without SP | SP1 | SP2 |
|---|---|---|---|
| Starter | Manual | Manual | Manual |
| Home Basic | Manual | Manual | Manual |
| Home Premium | Manual | Manual | Manual |
| Business | Manual | Manual | Manual |
| Ultimate | Manual | Manual | Manual |
| Display name: | Function Discovery Provider Host |
| Service name: | fdPHost |
| Type: | share |
| Path: | %WinDir%\system32\svchost.exe -k LocalService |
| File: | %WinDir%\system32\fdPHost.dll |
| Error control: | normal |
| Object: | NT AUTHORITY\LocalService |
| Privileges: |
|
The Function Discovery Provider Host service starts as NT AUTHORITY\LocalService and runs in a shared process of svchost.exe. If Function Discovery Provider Host fails to start, the error is recorded into the Event Log. Windows Vista startup proceeds, but a message box is displayed informing you that the fdPHost service has failed to start. If you disable this service, then 2 other services will be unable to start (see the "Dependencies" section below).
The Function Discovery Provider Host service won't start, if the following system components are stopped or disabled:
If the Function Discovery Provider Host is stopped, the following services will not start and initialize:
1. Select your Windows Vista edition and Service Pack, and then click on the Download button below.
2. Save the RestoreFunctionDiscoveryProviderHostWindowsVista.bat file to any folder on your hard drive.
3. Right-click the downloaded batch file and select Run as administrator.
4. Restart the computer to save changes.
Note. Make sure that the fdPHost.dll file exists in the %WinDir%\system32 folder. If this file is missing you can try to restore it from your Windows Vista installation media.