This service manages persistent subscriptions to events from remote sources that support WS-Management protocol. This includes Windows Vista event logs, hardware and IPMI-enabled event sources. The service stores forwarded events in a local Event Log. If this service is stopped or disabled event subscriptions cannot be created and forwarded events cannot be accepted.
This service also exists in Windows 10, 11, 8 and Vista.
| Windows 7 edition | without SP | SP1 |
|---|---|---|
| Starter | Manual | Manual |
| Home Basic | Manual | Manual |
| Home Premium | Manual | Manual |
| Professional | Manual | Manual |
| Ultimate | Manual | Manual |
| Enterprise | Manual | Manual |
| Display name: | Windows Event Collector |
| Service name: | Wecsvc |
| Type: | share |
| Path: | %WinDir%\system32\svchost.exe -k NetworkService |
| File: | %WinDir%\system32\wecsvc.dll |
| Error control: | normal |
| Object: | NT AUTHORITY\NetworkService |
| Privileges: |
|
The Windows Event Collector service runs as NT AUTHORITY\NetworkService in a shared process. It shares the executable file with other services. If the Windows Event Collector fails to load or initialize, the error is recorded into the Event Log. Windows 7 startup should proceed, but a message box is displayed informing you that the Wecsvc service has failed to start.
Windows Event Collector will not start, if the following services are stopped or disabled:
1. Select your Windows 7 edition and Service Pack, and then click on the Download button below.
2. Save the RestoreWindowsEventCollectorWindows7.bat file to any folder on your hard drive.
3. Right-click the downloaded batch file and select Run as administrator.
4. Restart the computer to save changes.
Note. Make sure that the wecsvc.dll file exists in the %WinDir%\system32 folder. If this file is missing you can try to restore it from your Windows 7 installation media.